*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / priority / priority-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{6,7,8})
6
7 inherit distutils-r1
8
9 DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
10 HOMEPAGE="https://python-hyper.org/priority/en/latest/
11         https://github.com/python-hyper/priority
12         https://pypi.org/project/priority/"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
22 "
23
24 PATCHES=(
25         "${FILESDIR}"/priority-1.3.0-test-timeout.patch
26 )
27
28 distutils_enable_tests pytest