*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / positional / positional-1.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A decorator which enforces only some args may be passed positionally."
10 HOMEPAGE="https://github.com/morganfainberg/positional"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
20 RDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]
21         dev-python/wrapt[${PYTHON_USEDEP}]"