*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pkgconfig / pkgconfig-1.2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Interface Python with pkg-config"
11 HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/nose[${PYTHON_USEDEP}] )
24 "
25
26 python_prepare_all() {
27         sed -e '/nose/d' -i setup.py || die
28         distutils-r1_python_prepare_all
29 }
30
31 python_test() {
32         nosetests || die
33 }