*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / piexif / piexif-1.0.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Exif manipulation with pure Python"
11 HOMEPAGE="https://github.com/hMatoba/Piexif
12         https://pypi.org/project/piexif/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
22         app-arch/unzip
23         test? ( dev-python/pillow )"
24
25 python_test() {
26         "${PYTHON}" setup.py test
27 }