*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pgspecial / pgspecial-1.11.9.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python implementation of postgres meta commands"
10 HOMEPAGE="https://github.com/dbcli/pgspecial"
11 SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-python/click-4.1[${PYTHON_USEDEP}]
20         >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
21         >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
22 "
23
24 distutils_enable_tests pytest