*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pelican-minify / pelican-minify-0.9.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit distutils-r1
8
9 DESCRIPTION="An HTML minification plugin for Pelican, the static site generator."
10 HOMEPAGE="https://pypi.org/project/pelican-minify/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Unlicense"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="${DEPEND}
20         >=dev-python/joblib-0.9[${PYTHON_USEDEP}]
21         >=app-text/htmlmin-0.1.5[${PYTHON_USEDEP}]
22         >=app-text/pelican-3.1.1[${PYTHON_USEDEP}]"