*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pathspec / pathspec-0.6.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Utility library for gitignore style pattern matching of file paths."
10 HOMEPAGE="https://github.com/cpburnz/python-path-specification https://pypi.org/project/pathspec/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MPL-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
16 IUSE=""
17
18 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 python_test() {
21         esetup.py test
22 }