*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / owslib / owslib-0.16.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7 inherit distutils-r1
8
9 DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
10 HOMEPAGE="https://geopython.github.io/OWSLib"
11 SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17
18 RDEPEND="
19         dev-python/pyproj[${PYTHON_USEDEP}]
20         dev-python/python-dateutil[${PYTHON_USEDEP}]
21         dev-python/pytz[${PYTHON_USEDEP}]
22         dev-python/requests[${PYTHON_USEDEP}]
23         || (
24                 dev-python/elementtree[${PYTHON_USEDEP}]
25                 dev-python/lxml[${PYTHON_USEDEP}]
26         )
27 "
28 DEPEND="
29         dev-python/setuptools[${PYTHON_USEDEP}]
30         test? (
31                 dev-python/pillow[${PYTHON_USEDEP}]
32                 dev-python/pytest[${PYTHON_USEDEP}]
33         )
34 "
35
36 RESTRICT="test" # tests require WAN access
37
38 S="${WORKDIR}/OWSLib-${PV}"
39
40 python_test() {
41         "${EPYTHON}" "${S}/setup.py" test || die
42 }