*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / oslo-rootwrap / oslo-rootwrap-5.13.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
10 HOMEPAGE="https://pypi.org/project/oslo.config/"
11 SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
12 S="${WORKDIR}/oslo.rootwrap-${PV}"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
21         !~dev-python/pbr-2.1.0"
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
23         ${CDEPEND}
24         test? (
25                 >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
26                 >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
27                 >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
28                 >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
29                 >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
30                 >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
31                 >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
32                 >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
33                 >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
34                 !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
35                 <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
36                 >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
37                 >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
38                 dev-python/nose[${PYTHON_USEDEP}] )"
39 RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
40
41 python_prepare_all() {
42         sed -i '/^hacking/d' test-requirements.txt || die
43         distutils-r1_python_prepare_all
44 }
45
46 python_test() {
47         sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
48         nosetests tests/ || die "test failed under ${EPYTHON}"
49 }