*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / os-resource-classes / os-resource-classes-0.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A list of standardized resource classes for OpenStack."
10 HOMEPAGE="https://github.com/openstack/os-resource-classes"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE=""
17
18 CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
19         !~dev-python/pbr-2.1.0"
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         ${CDEPEND}"
22 RDEPEND="
23         ${CDEPEND}
24         >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
25
26 python_prepare_all() {
27         sed -i '/^hacking/d' test-requirements.txt || die
28         distutils-r1_python_prepare_all
29 }