dev-python/objgraph: keyworded 3.4.1 for ia64, bug #717946
[gentoo.git] / dev-python / objgraph / objgraph-3.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Draws Python object reference graphs with graphviz"
11 HOMEPAGE="https://mg.pov.lt/objgraph/"
12 SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
16 SLOT="0"
17 IUSE="doc test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="media-gfx/graphviz"
21 DEPEND="dev-python/setuptools
22         test? ( media-gfx/xdot )"
23
24 PATCHES=(
25         "${FILESDIR}/objgraph-3.4.1-tests.patch"
26 )
27
28 distutils_enable_tests unittest
29
30 python_install_all() {
31         use doc && local HTML_DOCS=(  docs/* )
32         distutils-r1_python_install_all
33 }