*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / numpydoc / numpydoc-0.8.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
11 HOMEPAGE="https://pypi.org/project/numpydoc/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/jinja[${PYTHON_USEDEP}]
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         dev-python/sphinx[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         test? (
26                 dev-python/nose[${PYTHON_USEDEP}]
27                 >=dev-python/matplotlib-1.4.0[${PYTHON_USEDEP}]
28         )"
29
30 python_test() {
31         esetup.py test
32 }