*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / numba / numba-0.39.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
11 HOMEPAGE="http://numba.pydata.org/"
12 SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="examples test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         >=dev-python/llvmlite-0.22.0[${PYTHON_USEDEP}]
22         dev-python/numpy[${PYTHON_USEDEP}]
23         virtual/python-enum34[${PYTHON_USEDEP}]
24         virtual/python-funcsigs[${PYTHON_USEDEP}]
25         virtual/python-singledispatch[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         dev-python/setuptools[${PYTHON_USEDEP}]
29         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
30 "
31
32 PATCHES=(
33         "${FILESDIR}"/numba-skip-tests.patch
34 )
35
36 python_test() {
37         cd "${BUILD_DIR}/lib" || die
38         ${EPYTHON} -m numba.runtests -v || die
39 }
40
41 python_install_all() {
42         distutils-r1_python_install_all
43         if use examples; then
44                 insinto /usr/share/doc/${PF}
45                 doins -r examples
46                 docompress -x /usr/share/doc/${PF}/examples
47         fi
48 }