*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / nuitka / nuitka-0.6.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit distutils-r1 eutils
8
9 DESCRIPTION="Python to native compiler"
10 HOMEPAGE="https://www.nuitka.net"
11 SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18
19 RDEPEND="${DEPEND}
20         dev-python/appdirs[${PYTHON_USEDEP}]
21         dev-util/scons[${PYTHON_USEDEP}]
22         "
23
24 S="${WORKDIR}/${P^}"
25
26 pkg_postinst() {
27         optfeature "support for stand-alone executables" app-admin/chrpath
28 }