*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ntlm-auth / ntlm-auth-1.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Calculates NTLM Authentication codes"
11 HOMEPAGE="https://github.com/jborean93/ntlm-auth"
12 SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="dev-python/six[${PYTHON_USEDEP}]
20         $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)"
21 DEPEND="${RDEPEND}"