*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / nosexcover / nosexcover-1.0.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Extends nose.plugins.cover to add Cobertura-style XML reports"
11 HOMEPAGE="https://github.com/cmheisel/nose-xcover/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm x86"
17 IUSE=""
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/nose[${PYTHON_USEDEP}]
22         >=dev-python/coverage-3.4[${PYTHON_USEDEP}]"
23 RDEPEND="${DEPEND}"
24
25 python_test() {
26         nosetests -v nosexcover/tests.py || die
27 }