*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / netifaces / netifaces-0.10.9.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Portable network interface information"
10 HOMEPAGE="
11         https://pypi.org/project/netifaces/
12         https://alastairs-place.net/projects/netifaces/
13         https://github.com/al45tair/netifaces
14 "
15 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 PATCHES=( "${FILESDIR}"/${PN}-0.10.4-remove-osx-fix.patch )