*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / netifaces / netifaces-0.10.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Portable network interface information"
11 HOMEPAGE="
12         https://pypi.org/project/netifaces/
13         https://alastairs-place.net/projects/netifaces/
14         https://github.com/al45tair/netifaces
15 "
16 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
21
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
23
24 PATCHES=( "${FILESDIR}"/${PN}-0.10.4-remove-osx-fix.patch )