*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / neovim-python-client / neovim-python-client-0.4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7 inherit distutils-r1
8
9 DESCRIPTION="Python client for Neovim"
10 HOMEPAGE="https://github.com/neovim/pynvim"
11 SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 S="${WORKDIR}/pynvim-${PV}"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~x86"
17
18 DEPEND="
19         dev-python/msgpack[${PYTHON_USEDEP}]
20         virtual/python-greenlet[${PYTHON_USEDEP}]
21         $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
22
23 RDEPEND="
24         ${DEPEND}
25         app-editors/neovim"
26
27 distutils_enable_tests pytest
28
29 python_prepare_all() {
30         # allow useage of renamed msgpack
31         sed -r -i "/^msgpack/d ; s:[\"']pytest-runner[\"'](,|)::" setup.py || die
32         distutils-r1_python_prepare_all
33 }