*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / nbsphinx / nbsphinx-0.2.14.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Jupyter Notebook Tools for Sphinx"
11 HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/docutils[${PYTHON_USEDEP}]
21         dev-python/jinja[${PYTHON_USEDEP}]
22         dev-python/nbconvert[${PYTHON_USEDEP}]
23         dev-python/nbformat[${PYTHON_USEDEP}]
24         >=dev-python/sphinx-1.3.2[${PYTHON_USEDEP}]
25         dev-python/traitlets[${PYTHON_USEDEP}]
26         "
27 DEPEND="${RDEPEND}"