*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / namespace-paste / namespace-paste-1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7 inherit python-r1
8
9 DESCRIPTION="Namespace package declaration for paste"
10 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages"
11 SRC_URI=""
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
16 IUSE=""
17
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         ${PYTHON_DEPS}"
20 DEPEND="${PYTHON_DEPS}"
21
22 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
23
24 src_unpack() {
25         mkdir -p "${S}"/paste || die
26         cat > "${S}"/paste/__init__.py <<-EOF || die
27                 __import__('pkg_resources').declare_namespace(__name__)
28         EOF
29 }
30
31 src_install() {
32         python_foreach_impl python_domodule paste
33 }