*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / munkres / munkres-1.0.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
11 HOMEPAGE="https://pypi.org/project/munkres/"
12 SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 S="${WORKDIR}/${PN}-release-${PV}"
19
20 python_test() {
21         "${PYTHON}" ${PN}.py || die
22 }