*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / mongoengine / mongoengine-0.10.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7
8 inherit distutils-r1
9
10 RESTRICT="test" # connects to local DB and other nonsense
11
12 DESCRIPTION="A Python Object-Document-Mapper for working with MongoDB"
13 HOMEPAGE="https://github.com/MongoEngine/mongoengine/"
14 SRC_URI="https://github.com/MongoEngine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE="test"
20
21 RDEPEND=""
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
23         dev-python/pymongo[${PYTHON_USEDEP}]"
24
25 python_prepare_all() {
26         sed -i -e 's/tests/tests*/g' setup.py || die "Failed to fix test removal thingy"
27         distutils-r1_python_prepare_all
28 }
29
30 python_test() {
31         nosetests || die "Testing failed with ${EPYTHON}"
32 }