*/*: Drop stable ia64 keywords
[gentoo.git] / dev-python / mock / mock-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
11 HOMEPAGE="https://github.com/testing-cabal/mock"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 CDEPEND="
21         >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
22         $(python_gen_cond_dep '
23                 dev-python/funcsigs[${PYTHON_USEDEP}]
24         ' -2)"
25 DEPEND="
26         >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
27         test? (
28                 ${CDEPEND}
29                 dev-python/nose[${PYTHON_USEDEP}]
30                 >=dev-python/unittest2-1.1.0[${PYTHON_USEDEP}]
31         )"
32 RDEPEND="
33         ${CDEPEND}
34         >=dev-python/six-1.9[${PYTHON_USEDEP}]
35 "
36
37 python_test() {
38         nosetests --verbose || die "tests fail under ${EPYTHON}"
39 }
40
41 python_install_all() {
42         local DOCS=( docs/{conf.py,index.txt} AUTHORS ChangeLog NEWS README.rst )
43
44         distutils-r1_python_install_all
45 }