*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / microversion-parse / microversion-parse-0.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A simple parser for OpenStack microversion headers"
10 HOMEPAGE="https://github.com/openstack/microversion-parse"
11 SRC_URI="mirror://pypi/${PN:0:1}/microversion_parse/microversion_parse-${PV}.tar.gz"
12 S="${WORKDIR}/microversion_parse-${PV}"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
23         ${CDEPEND}"
24 RDEPEND="
25         ${CDEPEND}
26 "