*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / marshmallow / marshmallow-3.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(  python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
10 HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         dev-python/python-dateutil[${PYTHON_USEDEP}]
21 "
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/pytest[${PYTHON_USEDEP}]
26                 dev-python/simplejson[${PYTHON_USEDEP}]
27         )"
28
29 src_prepare() {
30         distutils-r1_src_prepare
31 }
32
33 python_test() {
34         py.test -v || die "tests failed under ${EPYTHON}"
35 }