*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / lz4 / lz4-0.10.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="LZ4 Bindings for Python"
11 HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
21         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         nosetests || die
25 }