*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / libpillowfight / libpillowfight-0.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7} )
6
7 inherit distutils-r1
8
9 MY_PN="pypillowfight"
10
11 DESCRIPTION="Small library containing various image processing algorithms"
12 HOMEPAGE="https://github.com/openpaperwork/libpillowfight"
13 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
24
25 S=${WORKDIR}/${MY_PN}-${PV}
26
27 python_prepare_all() {
28         sed -e "/'nose>=1.0'/d" -i setup.py || die
29         distutils-r1_python_prepare_all
30 }