*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ldap3 / ldap3-2.2.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
11 HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.org/project/ldap3/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 # The tests are a mess, and the test config is not included in the
19 # PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
20 # https://github.com/cannatag/ldap3/blob/master/test/config.py).
21 RESTRICT="test"
22
23 RDEPEND="
24         dev-python/pyasn1[${PYTHON_USEDEP}]"
25
26 DEPEND="
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 dev-python/nose[${PYTHON_USEDEP}]
30                 ${RDEPEND} )"
31
32 python_test() {
33         nosetests -v -s test || die
34 }