*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jupyter / jupyter-1.0.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
11 HOMEPAGE="https://jupyter.org"
12 SRC_URI="
13         mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
14         https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
15         "
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc"
21
22 RDEPEND="
23         dev-python/notebook[${PYTHON_USEDEP}]
24         dev-python/qtconsole[${PYTHON_USEDEP}]
25         dev-python/jupyter_console[${PYTHON_USEDEP}]
26         dev-python/nbconvert[${PYTHON_USEDEP}]
27         dev-python/ipykernel[${PYTHON_USEDEP}]
28         dev-python/ipywidgets[${PYTHON_USEDEP}]"
29 DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
30 PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
31
32 PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
33
34 python_prepare_all() {
35         # Prevent un-needed download during build
36         if use doc; then
37                 sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
38         fi
39
40         distutils-r1_python_prepare_all
41 }
42
43 python_compile_all() {
44         use doc && emake -C docs html
45 }
46
47 python_install_all() {
48         use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
49         distutils-r1_python_install_all
50 }