*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jsonref / jsonref-0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7})
6
7 inherit eutils distutils-r1
8
9 DESCRIPTION="An implementation of JSON Reference for Python"
10 HOMEPAGE="https://github.com/gazpachoking/jsonref https://pypi.org/project/jsonref/"
11 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
20
21 python_test() {
22         py.test tests.py || die
23 }