*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jsonpatch / jsonpatch-1.21.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 RESTRICT="test"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
12 HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19
20 RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( ${RDEPEND} )"
23
24 python_test() {
25         "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
26         "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
27 }