*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jpype / jpype-0.6.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit java-pkg-2 distutils-r1
9
10 DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
11 HOMEPAGE="https://github.com/originell/jpype"
12 SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.zip -> ${P}.zip"
13
14 LICENSE="Apache-1.1"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="doc examples"
18
19 S="${WORKDIR}/${P}"
20
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         >=virtual/jdk-1.6"
24
25 PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
26
27 python_install() {
28         use doc && local DOCS=( doc/* )
29         use examples && local EXAMPLES=( examples/. )
30         distutils-r1_python_install
31 }