*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jikanpy / jikanpy-3.4.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python wrapper for jikan.moe API."
10 HOMEPAGE="https://pypi.org/project/jikanpy/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         dev-python/aiohttp[${PYTHON_USEDEP}]
20         dev-python/requests[${PYTHON_USEDEP}]
21 "