*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / jdcal / jdcal-1.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Julian dates from proleptic Gregorian and Julian calendars"
11 HOMEPAGE="https://github.com/phn/jdcal"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
16 SLOT="0"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         pytest -vv || die
25 }