*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / itsdangerous / itsdangerous-0.24-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
11 HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
12 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 # Required for running tests.py
21 DISTUTILS_IN_SOURCE_BUILD=1
22
23 python_test() {
24         if python_is_python3; then
25                 2to3 -f unicode -nw --no-diffs tests.py
26         fi
27         "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
28 }