*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / iso8601 / iso8601-0.1.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Simple module to parse ISO 8601 dates"
11 HOMEPAGE="https://pypi.org/project/iso8601/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 distutils_enable_tests pytest