*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / intreehooks / intreehooks-1.0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7 inherit distutils-r1
8
9 DESCRIPTION="Load a PEP 517 backend from inside the source tree"
10 HOMEPAGE="https://pypi.org/project/intreehooks https://github.com/takluyver/intreehooks"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="examples"
17
18 RDEPEND="
19         dev-python/toml[${PYTHON_USEDEP}]
20 "
21 BDEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23 "
24
25 distutils_enable_tests pytest
26
27 python_prepare_all() {
28         # replace pytoml with toml
29         sed -e 's:pytoml:toml:' \
30                 -i setup.py intreehooks.py || die
31
32         distutils-r1_python_prepare_all
33 }
34
35 python_install_all() {
36         local -a DOCS=( README.rst )
37         use examples && dodoc -r examples
38
39         distutils-r1_python_install_all
40 }