*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / idna / idna-2.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
11 HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 python_test() {
22         esetup.py test
23 }