*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / idna-ssl / idna-ssl-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
11 HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.org/project/idna_ssl/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="amd64 ~arm ~arm64 x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"