*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / hyperlink / hyperlink-17.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6)
6
7 inherit distutils-r1
8
9 DESCRIPTION="A featureful, correct URL for Python"
10 HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
11 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? (
23                 >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
24                 >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
25         )
26 "
27
28 python_test() {
29         PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
30                 py.test -v || die
31         cd test
32 }