*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / httpauth / httpauth-0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
11 HOMEPAGE="https://github.com/jonashaag/httpauth/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="ISC"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 BDEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( dev-python/nose[${PYTHON_USEDEP}] )
23 "
24
25 python_test() {
26         nosetests -v tests.py || die "tests failed with ${EPYTHON}"
27 }