*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / httmock / httmock-1.2.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A mocking library for requests"
11 HOMEPAGE="https://github.com/patrys/httmock"
12 SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 python_test() {
22         esetup.py test
23 }