*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / hachoir-parser / hachoir-parser-1.3.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Package of Hachoir parsers used to open binary files"
11 HOMEPAGE="https://pypi.org/project/hachoir-parser/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE=""
18
19 RDEPEND=">=dev-python/hachoir-core-1.3[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 python_configure_all() {
24         mydistutilsargs=( --setuptools )
25 }