*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / hachoir-core / hachoir-core-1.3.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
11 HOMEPAGE="https://pypi.org/project/hachoir-core/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 python_configure_all() {
23         mydistutilsargs=( --setuptools )
24 }
25
26 python_test() {
27         "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
28 }