*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / grpcio / grpcio-1.21.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7 inherit distutils-r1 multiprocessing
8
9 DESCRIPTION="High-performance RPC framework (python libraries)"
10 HOMEPAGE="https://grpc.io"
11 SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~x86"
16
17 RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
18         >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
19         dev-python/protobuf-python[${PYTHON_USEDEP}]
20         dev-python/six[${PYTHON_USEDEP}]
21         net-dns/c-ares:=
22         !<net-libs/grpc-1.16.0[python]
23         sys-libs/zlib:=
24         virtual/python-enum34[${PYTHON_USEDEP}]
25         virtual/python-futures[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         dev-python/setuptools[${PYTHON_USEDEP}]
29 "
30
31 python_configure_all() {
32         export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
33         export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
34         export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
35         export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
36         export GRPC_PYTHON_BUILD_WITH_CYTHON=1
37         export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
38 }