*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / grpcio-tools / grpcio-tools-1.18.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7 inherit distutils-r1 multiprocessing
8
9 DESCRIPTION="Protobuf code generator for gRPC"
10 HOMEPAGE="https://grpc.io"
11 SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="dev-python/cython[${PYTHON_USEDEP}]
18         ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
19         dev-python/protobuf-python[${PYTHON_USEDEP}]
20         !<net-libs/grpc-1.16.0[tools]
21 "
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24 "
25
26 python_compile() {
27         export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
28         export GRPC_PYTHON_BUILD_WITH_CYTHON=1
29         distutils-r1_python_compile
30 }