*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-python / google-apputils / google-apputils-0.4.2-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 # Python 3: https://github.com/google/google-apputils/issues/9
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Collection of utilities for building Python applications"
12 HOMEPAGE="https://github.com/google/google-apputils"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         dev-python/namespace-google[${PYTHON_USEDEP}]
23         >=dev-python/python-dateutil-1.4[${PYTHON_USEDEP}]
24         >=dev-python/python-gflags-1.4[${PYTHON_USEDEP}]
25         >=dev-python/pytz-2010[${PYTHON_USEDEP}]"
26 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
27         test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
28
29 PATCHES=(
30         "${FILESDIR}/0.4.2-sh_test-env.patch"
31 )
32
33 src_unpack() {
34         default
35         chmod -R a+rX,u+w,g-w,o-w ${P} || die
36 }
37
38 python_test() {
39         esetup.py google_test
40 }
41
42 python_install_all() {
43         distutils-r1_python_install_all
44
45         find "${D}" -name '*.pth' -delete || die
46 }