*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / globre / globre-0.1.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A glob matching library, providing an interface similar to the 're' module"
11 HOMEPAGE="https://pypi.org/project/globre/ https://github.com/metagriffin/globre"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-3+"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
25         )"
26
27 python_test() {
28         nosetests --verbose || die
29 }