*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / git-python / git-python-1.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 MY_PN="GitPython"
12 MY_PV="${PV/_rc/.RC}"
13 MY_P="${MY_PN}-${MY_PV}"
14
15 DESCRIPTION="Library used to interact with Git repositories"
16 HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
17 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
22 IUSE="test"
23
24 # Tests dont make sense without a git repo
25 RESTRICT="test"
26
27 RDEPEND="
28         dev-vcs/git
29          >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
30 DEPEND="${RDEPEND}
31         dev-python/setuptools[${PYTHON_USEDEP}]
32         test? (
33                 dev-python/nose[${PYTHON_USEDEP}]
34                 dev-python/mock[${PYTHON_USEDEP}]
35         )"
36 # $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
37 # is the correct entry for mock, however while RESTRICT="test"
38 # there is little point in setting it since it is inactive
39 S="${WORKDIR}/${MY_P}"